
Stallion 3D Menus Stallion 3D Tutorial

 

The Menu System 
 
Stallion 3D is driven using the main menu bar at the 
top of the program’s main window.  This section lists 
and describes the functions of the menu system. 
 
Item Under the File Menu 
The file menus control the opening and saving of 
project files, graphs and tables.  It is also used to 
end the execution of the Stallion 3D program. 
 
New Project 
This option starts a new project.  It clears the current 
data in the program and reset the parameters to the 
default values.  The program starts with a 1 X1 
meter surface with NACA 0012 airfoils. 
 
Open Project 
This option clears the current data and allows the 
user to import a project for the disk that was 
previously saved with the Save Project menu option. 
 
Import MSA Design 
This option imports a design from the MultiSurface 
Aerodynamics software.  Only the design can be 
imported with this menu.  The flow parameters and 
other options are not imported into Stallion 3D. 
 
Insert MSA Design (Mirror Image) 
This option is similar to the above item but imports 
the mirror image of the MultiSurface Aerodynamics 
design.  It is useful to automatically create the left 
side of a wing when only the right side is available 
(or vice versa). 
 
Save Project 
This option saves the current design (surfaces, 
imported .stl file) and the flow parameters as a single 
file.  It also saves the streamlines settings.  It does 
not save the flow field data (velocity, density, 
pressure, etc.). 
 
Export MSA Surfaces 
Export surfaces designed in Stallion 3D so they can 
be read in MultiSurface Aerodynamics.  This option 
does not export STL imports and flow parameters. 
 
 
 

Export STL File 
Export both STL imports (facets) and surfaces 
designed in Stallion 3D as an ASCII STL files. 
 
Export Graph (.BMP) 
First select the active window to export the picture 
as a MS Windows BMP file. 
 
Export Table 
Export the table in the active windows as an ASCII 
(text file).  This command will not work if the active 
window is not a table. 
 
Export Table as .CSV File 
Export the table in the active window as a comma 
separated value (csv) file.  This is useful to export a 
table to a spread sheet program since these 
programs can import and format csv files. 
 
Print Graph 
Print the graph in the selected window. 
 
Print Table 
Print the table in the selected window. 
 
Exit 
Exit the Stallion 3D program. 
 
Items Under the Edit Menu 
The items in the edit menu allows the user to copy 
graphs and data from Stallion 3D and then paste this 
information into other programs using the MS 
Windows clipboard. 
 
Copy Graph 
Copy the graph in the selected window.  The graph 
can then be pasted into a program such as Microsoft 
Word. 
 
Copy Table 
Copy the table in the selected window. 
 
Items Under the View Menu 
The View menu commands allow the user to view 
the designs in 3D, select and zoom portions of the 
screen. 
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3D Surfaces 
Invoke the viewer for 3-dimensional surfaces. 
 
Zoom 
Click this menu and then drag out a rectangle 
around a region in the active window to isolate that 
portion of the drawing.  The zoom menu allows the 
user to enhance regions of the 3D Viewer, the 
Design Window and other graphics screens. 
 
Unzoom (Auto) 
Return the screen to the original view. 
 
 
Items Under the Design Menu 
The design menu allows the user to introduce 3-
dimensional objects into Stallion for analysis.  The 
menu allows addition of wing and bodies developed 
in the built-in geometry editor.  It also can be used to 
import .stl files that were developed in external CAD 
software packages using the Import/Edit STL File 
sub menu. 
 
Top Elevation 
View the design from the top elevation. 
 
Side Elevation 
View the design in the side elevation. 
 
Front Elevation 
View the design in the front (back) elevation. 
 
Import/Edit STL File  
Import, rotate, scale and translate an ascii stl file into 
Stallion 3D. 
 
Design/Edit Body of Revolution 
Enter the coordinates of a body of revolution into 
Stallion 3D.   This menu item allows the user to 
choose from NACA airfoils shapes and custom 
coordinates to enter the surface of revolution.  The 
user can also choose the resolution of the model in 
the circumferential and axial directions. 
 
3D View 
Invoke the window to view the 3-dimensional model 
in three-dimensions.  This window has functions to 
rotate the model about the x, y and z axes. 
 
 
 

Group Surfaces 
The lifting surfaces (wings) can be grouped so they 
can move as a single surface.  They can also be 
locked to prevent accidental movement. 
 
Edit Last Surface 
A quick way to edit the last surface. 
 
Add Surface 
Add an extra lifting surface to the 3-dimensional 
model. 
 
Items Under the Flow Field Menu 
The flow field menu allows the user to define the 
flow parameters such as speed, direction, density 
and fluid type (air or water). 
 
Flow Parameters 
The dialog box invoked by this menu item allows the 
user to define the flow velocity, density and fluid 
type.  The dialog box also defines measurements, 
units and parameters used to define the lift, drag and 
moment coefficients. 
 
Change Angle of Attack 
This is a shortcut to the angle of attack dialog box. 
 
Flow Field Options 
A shortcut to the flow field parameters dialog box. 
 
Items Under the CFD Solver Menu 
The CFD Solver menu allows the user to define the 
size and extent of the computational grid, setup 
boundary conditions (radiation or reflecting), 
integration accuracy and boundary spacing.  The 
user can also select between the Euler or Navier-
Stokes equations to model the flow field. 
 
Setup CFD Solver 
This option invokes the dialog box to set the grid 
size and boundaries.  The dialog box also sets the 
boundary conditions, flow solver, solution accuracy 
and number of iterations. 
 
Generate Grid (Only) 
Automatically generates the computational grid 
based on the CFD solver parameters and geometry.  
This menu will generate only the grid.  It will not 
initiate the flow solver. 
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Generate Grid/Solve Flow 
This menu will generate the grid and then initiate the 
flow solver.   The solution will use the flow field 
parameters at infinity as the initial conditions. 
 
Solve Flow (From Initial Conditions) 
If a grid exists (either by generation from the above 
menu or from an existing solution), this menu will 
start the flow solver using the flow condition at 
infinity as the initial condition. 
 
Resume Solution 
Restart the solution if it was ended by the Stop 
Solution menu or if the solution was imported using 
the Open CFD Results menu. 
 
Stop Solution 
Stop the solution process at the current iteration.  
The solution can restart using the Resume Solution 
menu. 
 
Save CFD Results 
This option saves the flow variables, the entire 
computation grid, the geometry and other 
parameters.  This is a very large ascii file. 
 
Open CFD Results 
Loads the information saved by the Save CFD 
Results menu.  This operation can take a few 
minutes to complete based on the size of the 
computational grid. 
 
Items Under the Aerodynamics Data Menu 
The Aerodynamics Data menu allows the user to 
generate the lift, drag and moments coefficients 
generated by the geometry under the specified flow 
field.  In addition, the user can compute and export 
forces and moments based on the size of the 
geometry and the flow velocity magnitudes. 
 
Aerodynamics Coefficients 
Compute the lift, drag and moment coefficients.  In 
addition, the user can compute the forces and 
moments in the x, y, and z coordinate directions. 
 
Aerodynamics Force 
Compute the lift, drag and moments based on the 
flow parameters and geometry size.  The forces and 
moments are computed and presented in 
dimensional form. 
 

Force Integration Options 
Stallion 3D computes the forces acting on a 
geometry using two methods.  The first method is 
based on the integration of the pressure on the 
geometry surface.  The second method is based on 
integration on the Cartesian grid near the surface 
boundary.  The former method is more accurate for 
a good definition of the geometry. 
 
Save Aerodynamics Data 
This menu item saves the aerodynamic data in an 
ascii file. 
 
Items Under the Visualization Menu 
The Visualization menu is used to view the 3D 
geometry and the flow field.  The surface of the 
geometry can display the pressure, velocity, density 
or Mach number.   In addition, the user can set the 
parameters to display streamlines that start at 
arbitrary locations in the flow domain. 
 
View Geometry (Only) 
Use this menu to display only the geometry in the 3D 
viewer. This is useful to verify that the imported 
geometry is correct. 
 
View 3D Solution 
View the 3D solution superimposed on the geometry 
and the flow field.  Click on the menu to display 
pressures, velocity, density and Mach number on the 
surface of the geometry.  This menu also displays 
the streamlines and flow planes. 
 
Surface Color Options 
Use this menu to set the flow parameter that is 
displayed on the surface of the geometry.  The 
options are pressure, velocity, Mach number and 
density.  The dialog box can also set the range of 
values of the displayed variable. 
 
View Edit Streamlines 
This menu invokes the streamlines dialog box.  The 
parameters set the starting locations and number of 
streamlines.  
 
View Flow Plane (Slices) 
The flow planes can either display the computational 
grid or the flow variables at planes in the flow that 
are set by the user. 
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Reset Surface Values 
Reset to the default values. 
 
Items Under the Graphs Menu 
The graph menu items allow the user to plot surface 
line graphs at locations along the y-axis.  This is 
useful to graph flow variables at stations along the 
wing (for example). 
 
Pressure Coefficient (Cp) 
Plot the pressure as a function of x at a pre-defined 
y location. 
 
Velocity Ratio 
Plot the velocity ratio as a function of x at a pre-
defined y-location. 
 
Mach Numbers 
Plot the Mach number at a specified y-location. 
 
Density 
Plot the density as a function of x at pre-defined y-
location. 
 
Temperature 
Plot the temperature as a function of x at a 
predefined y-location 
 
Surface Graph Options 
This option set the y-location of the surface graph 
and set a range of values for x and z. 
 
Clear Graphs 
This menu removes all of the line graphs. 
 
Items Under the Airfoil Tool Menu 
Stallion 3D has an independent airfoil analysis tool 
based on a linear strength vortex panel method.  
The tool has a built-in library of airfoils and can be 
used to import and analyze custom shapes. 
 
Select/Modify Airfoil 
Use this menu to select or modify an airfoil.  The 
airfoil library contains NACA 4, 5 and 6-digit shapes 
in addition to airfoils from the UIUC airfoil database.  
Custom airfoils can be entered as ascii files or .dxf 
files (line and arc entities). 
 
Angle of Attack 
Set the angle of attack for the airfoil analysis. 
 

Reynolds No./Boundary Layer Options 
Set the Reynolds number for the airfoil analysis and 
other options (for example, stall prediction). 
 
Surface Pressure Coefficient (Cp) 
Graph the pressure coefficient on the surface of the 
airfoil as a function of chord length. 
 
Surface Cp with Cavitation No. 
Graph the cavitation number cut-off on the surface 
pressure coefficient plot. 
 
Surface Velocity Ratio 
Graph the velocity ratio on the upper and lower 
surfaces of the airfoil as a function of chord length. 
 
Cl. vs. AOA 
Graph the airfoil lift coefficient as a function of angle 
of attack.  The lift curve is based on the Reynolds 
number that was set in the above menu. 
 
Cm vs. AOA 
Graph the moment coefficient about the quarter 
chord location as a function of angle of attack. 
 
Cd vs. AOA 
Graph the profile drag coefficient as a function of 
angle of attack. 
 
Cl/Cd vs. AOA 
Graph the lift to drag ratio as a function of angle of 
attack. 
 
Export Data to Airfoil Organizer 
Export the airfoil data to the Airfoil Organizer 
software package. 
 
Display Graph Data 
Click this menu to display numerical values of the 
graph data.  The data can be copied and pasted into 
another program. 
 
Angle of Attack Range 
Set the angle of attack range for the above graphs. 
 
Clear Graphs 
Remove all the graphs and start over with a single 
graph. 
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Items Under the Graph Options Menu 
The Graph Options menu applies only to the 
selected graph window.  Click on the pertinent graph 
window and then use the following graph options to 
customize the graph. 
 
Manual Scaling/Axis Positions 
Usually, the scales are set to the minimum and 
maximum values of the independent and dependent 
variables.  Use this menu to set custom values for 
the horizontal and vertical axes variables. 
 
Set Automatic Scaling 
Return the graph to automatic scaling which simply 
uses the minimum and maximum values of the 
independent and dependent variables. 
 
User Defined Scales 
Define the range and domain for the graph. 
 
Proportional Scales 
This option selects the graph scales so that a circle 
will be displayed as a circle (not an oval). 
 
Labels 
Enter the graph title in the "Graph Title" box; the X-
Axis label in the "X-Axis Label" box and the Y-Axis 
label in the "Y-Axis Label" box. 
 
Edit Legend 
create a legend for line graphs based on the 
information in the "Line Graph Options" dialog box. 
 
You can display the legend box by selecting the 
"View" menu followed by the "Show Legend" choice.  
The legend can be placed at any location on the 
graph by dragging it with the mouse to the desired 
position.  If it is placed beyond the boundaries of the 
graph, it can be centered onto the graph by selecting 
the "View" followed by the "Center Legend" choice.    
 
The legend can be temporarily removed from the 
graph by selecting the "View" menu followed by the 
"Hide Legend" choice. 
 
Show Legend 
The legend can be placed at any location on the 
graph by dragging it with the mouse to the desired 
position.  If it is placed beyond the boundaries of the 
graph, it can be centered onto the graph by selecting 
the "View" followed by the "Center Legend" choice. 

Hide Legend 
Remove the legend from the graph. 
 
Legend Background Color 
The legend background color can be changed by 
clicking on this option.  This will invoke the color 
dialog box from which you can choose your desired 
legend color. 
 
Background Color 
You will be presented with the color dialog box from 
which you can select the background color of your 
choice. 
 
Border Color 
You will be presented with the color dialog box from 
which you can select the border color of your choice. 
 
Axis and Label Color 
Use the color dialog box to choose a suitable color 
for your graph labels and title text. 
 
Set Graph Size 
If you wish to change the size of your graph, you can 
select the "Graph" menu followed by the "Set Graph 
Size" choice.  You will be presented with the 
following dialog box with which you can manipulate 
the size of your graph. Use the "Width" box to enter 
the new width of your graph. Use the "Height" box to 
enter the new height of your graph. Use the "Units" 
box to choose between pixels, inches or centimeters 
for the units of your graph. 
 
Items Under the Window Menu 
These items arranges multiple windows in Stallion 
3D. 
 
Tile Horizontally 
Tile the windows in a horizontal arrangement. 
 
Tile Vertically 
Tile the windows in a vertical arrangement. 
 
Items Under the Help Menu 
The items under the help menu displays the built-in 
html help files. 
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